use strict;
my $str = '<span style="font-family: inherit; font-weight: inherit; line-height: 1.3;"> <b>including their</b> </span>
<span style="font-family: inherit; font-weight: inherit; line-height: 1.3;">StackOverflow</span>
<span class="MainLink" style="font-weight: bold"><a href="https://website.com/" style="color: #2f82de; text-decoration: none">link name</a></span>
<a href="http://www.google.com"><span>testing</span></a>';
my $regex = qr/(?:<span[^>]*?>)(?!<a)(.*?)(?:<\/span>)/p;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";