#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)\[chapter.*?name="(.*?)".*?\]"
Local $sString = "[toc][/toc]" & @CRLF & _
"Here is some content" & @CRLF & _
"[chapter name="hello"]xxx[/chapter]" & @CRLF & _
"In between content may come here" & @CRLF & _
"[chapter name="world"]yyy[/chapter]" & @CRLF & _
"Some more stuff"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")