import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[chapter.*?name=\"(.*?)\".*?\\]";
final String string = "[toc][/toc]\n"
+ "Here is some content\n"
+ "[chapter name=\"hello\"]xxx[/chapter]\n"
+ "In between content may come here\n"
+ "[chapter name=\"world\"]yyy[/chapter]\n"
+ "Some more stuff";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}