re = /\[chapter.*?name="(.*?)".*?\]/i
str = '[toc][/toc]
Here is some content
[chapter name="hello"]xxx[/chapter]
In between content may come here
[chapter name="world"]yyy[/chapter]
Some more stuff'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end