using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[chapter.*?name=""(.*?)"".*?\]";
string input = @"[toc][/toc]
Here is some content
[chapter name=""hello""]xxx[/chapter]
In between content may come here
[chapter name=""world""]yyy[/chapter]
Some more stuff";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}