using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^|[^A-Z]+)(P(O|0)?ST(AL)?[. ]*((O|0)FF(ICE)?)?[. ]*B(((O|0)?X)|IN)($|[^A-Z]))|(P(O|0)?ST(AL)?[. ]*((O|0)FF(ICE)?)?[. ]*B(((O|0)?X)|IN))($|[^A-Z])";
string input = @"P . .. 0 BIN";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}