import re
regex = re.compile(r"(^|[^A-Z]+)(P(O|0)?ST(AL)?[. ]*((O|0)FF(ICE)?)?[. ]*B(((O|0)?X)|IN)($|[^A-Z]))|(P(O|0)?ST(AL)?[. ]*((O|0)FF(ICE)?)?[. ]*B(((O|0)?X)|IN))($|[^A-Z])", flags=re.IGNORECASE)
test_str = "P . .. 0 BIN"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")