re = /(^|[^A-Z]+)(P(O|0)?ST(AL)?[. ]*((O|0)FF(ICE)?)?[. ]*B(((O|0)?X)|IN)($|[^A-Z]))|(P(O|0)?ST(AL)?[. ]*((O|0)FF(ICE)?)?[. ]*B(((O|0)?X)|IN))($|[^A-Z])/i
str = 'P . .. 0 BIN'
# Print the match result
str.match(re) do |match|
puts match.to_s
end