const regex = /(^|[^A-Z]+)(P(O|0)?ST(AL)?[. ]*((O|0)FF(ICE)?)?[. ]*B(((O|0)?X)|IN)($|[^A-Z]))|(P(O|0)?ST(AL)?[. ]*((O|0)FF(ICE)?)?[. ]*B(((O|0)?X)|IN))($|[^A-Z])/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^|[^A-Z]+)(P(O|0)?ST(AL)?[. ]*((O|0)FF(ICE)?)?[. ]*B(((O|0)?X)|IN)($|[^A-Z]))|(P(O|0)?ST(AL)?[. ]*((O|0)FF(ICE)?)?[. ]*B(((O|0)?X)|IN))($|[^A-Z])', 'i')
const str = `P . .. 0 BIN`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}