using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Tag:\s*(.*)\s*Tag";
string input = @"Example- Tag: This is a test string to show the content that has to be extracted.This is a test string to show the content that has to be extracted.This is a test string to show the content that. Tag: ABCDEF";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}