$re = '/Tag:\s*(.*)\s*Tag/m';
$str = 'Example- Tag: This is a test string to show the content that has to be extracted.This is a test string to show the content that has to be extracted.This is a test string to show the content that. Tag: ABCDEF';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);