re = /Tag:\s*(.*)\s*Tag/m
str = 'Example- Tag: This is a test string to show the content that has to be extracted.This is a test string to show the content that has to be extracted.This is a test string to show the content that. Tag: ABCDEF'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end