package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)Tag:\s*(.*)\s*Tag`)
var str = `Example- Tag: This is a test string to show the content that has to be extracted.This is a test string to show the content that has to be extracted.This is a test string to show the content that. Tag: ABCDEF`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}