const regex = /\s?\battr\s*=\s*"\s*"|\s?\battr\b\s*=(?![^=<>]*")(?!\s*=)|(?<!\<)\s*\battr\b(?![^=<>]*")(?!\s*=)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s?\\battr\\s*=\\s*"\\s*"|\\s?\\battr\\b\\s*=(?![^=<>]*")(?!\\s*=)|(?<!\\<)\\s*\\battr\\b(?![^=<>]*")(?!\\s*=)', 'g')
const str = `Nowy test:
<attr attr src="/test-image_1.jpg" attr = " " asd=" q" attr="test-image_1.jpg" attr qwe="as-d q-q" x="attr asd" >
Poprzedni test:
<img src="/test-image_1.jpg" attr="test-image_1" qwe="asd" attr=>
<img src="/test-image_1.jpg" attr= "test-image_1" qwe="asd" attr="">
<img src="/test-image_1.jpg" attr= "test-image_1" qwe="asd" attr=" ">
<img attr="a attr b" src="/test-imagalte_1.jpg" attr qwe="asd" />
<img src="/test- alt image_1.jpg" attr="test-image_1" attr= "" qwe="asd" >
<img src="/test-image_1.jpg" attr = " " asd=" q" attr="test-image_1" attr qwe="asd" >
<img src="/test-image_1.jpg" attr= "test-image_1" qwe="asd" attr=" d " attr = " d " attr= " d ">
<img attr="test-image_1" qwe="asd" attr >
<img attr="test-image_1" qwe="asd" battr >
<img attr="test-image_1" qwe="asd" attrh >
<img attr="test-image_1" qwe="asd" attr >
<img attr="test-image_1" qwe="asd" attr =>
<img attr="test-image_1" qwe="asd" attr=>
<img attr="test-image_1" qwe="asd" battr = "" >
<img attr="test-image_1" qwe="asd" attrh= " " >
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}