$re = '/\s?\battr\s*=\s*"\s*"|\s?\battr\b\s*=(?![^=<>]*")(?!\s*=)|(?<!\<)\s*\battr\b(?![^=<>]*")(?!\s*=)/';
$str = 'Nowy test:
<attr attr src="/test-image_1.jpg" attr = " " asd=" q" attr="test-image_1.jpg" attr qwe="as-d q-q" x="attr asd" >
Poprzedni test:
<img src="/test-image_1.jpg" attr="test-image_1" qwe="asd" attr=>
<img src="/test-image_1.jpg" attr= "test-image_1" qwe="asd" attr="">
<img src="/test-image_1.jpg" attr= "test-image_1" qwe="asd" attr=" ">
<img attr="a attr b" src="/test-imagalte_1.jpg" attr qwe="asd" />
<img src="/test- alt image_1.jpg" attr="test-image_1" attr= "" qwe="asd" >
<img src="/test-image_1.jpg" attr = " " asd=" q" attr="test-image_1" attr qwe="asd" >
<img src="/test-image_1.jpg" attr= "test-image_1" qwe="asd" attr=" d " attr = " d " attr= " d ">
<img attr="test-image_1" qwe="asd" attr >
<img attr="test-image_1" qwe="asd" battr >
<img attr="test-image_1" qwe="asd" attrh >
<img attr="test-image_1" qwe="asd" attr >
<img attr="test-image_1" qwe="asd" attr =>
<img attr="test-image_1" qwe="asd" attr=>
<img attr="test-image_1" qwe="asd" battr = "" >
<img attr="test-image_1" qwe="asd" attrh= " " >
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);