# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\s?\battr\s*=\s*\"\s*\"|\s?\battr\b\s*=(?![^=<>]*\")(?!\s*=)|(?<!\<)\s*\battr\b(?![^=<>]*\")(?!\s*=)"
test_str = ("Nowy test:\n"
"<attr attr src=\"/test-image_1.jpg\" attr = \" \" asd=\" q\" attr=\"test-image_1.jpg\" attr qwe=\"as-d q-q\" x=\"attr asd\" >\n\n"
"Poprzedni test:\n"
"<img src=\"/test-image_1.jpg\" attr=\"test-image_1\" qwe=\"asd\" attr=>\n"
"<img src=\"/test-image_1.jpg\" attr= \"test-image_1\" qwe=\"asd\" attr=\"\">\n"
"<img src=\"/test-image_1.jpg\" attr= \"test-image_1\" qwe=\"asd\" attr=\" \">\n"
"<img attr=\"a attr b\" src=\"/test-imagalte_1.jpg\" attr qwe=\"asd\" />\n"
"<img src=\"/test- alt image_1.jpg\" attr=\"test-image_1\" attr= \"\" qwe=\"asd\" >\n"
"<img src=\"/test-image_1.jpg\" attr = \" \" asd=\" q\" attr=\"test-image_1\" attr qwe=\"asd\" >\n\n\n"
"<img src=\"/test-image_1.jpg\" attr= \"test-image_1\" qwe=\"asd\" attr=\" d \" attr = \" d \" attr= \" d \">\n"
"<img attr=\"test-image_1\" qwe=\"asd\" attr >\n"
"<img attr=\"test-image_1\" qwe=\"asd\" battr >\n"
"<img attr=\"test-image_1\" qwe=\"asd\" attrh >\n\n\n"
"<img attr=\"test-image_1\" qwe=\"asd\" attr >\n"
"<img attr=\"test-image_1\" qwe=\"asd\" attr =>\n"
"<img attr=\"test-image_1\" qwe=\"asd\" attr=>\n"
"<img attr=\"test-image_1\" qwe=\"asd\" battr = \"\" >\n"
"<img attr=\"test-image_1\" qwe=\"asd\" attrh= \" \" >\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.