import Foundation
let pattern = #"\s?\battr\s*=\s*"\s*"|\s?\battr\b\s*=(?![^=<>]*")(?!\s*=)|(?<!\<)\s*\battr\b(?![^=<>]*")(?!\s*=)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Nowy test:
<attr attr src="/test-image_1.jpg" attr = " " asd=" q" attr="test-image_1.jpg" attr qwe="as-d q-q" x="attr asd" >
Poprzedni test:
<img src="/test-image_1.jpg" attr="test-image_1" qwe="asd" attr=>
<img src="/test-image_1.jpg" attr= "test-image_1" qwe="asd" attr="">
<img src="/test-image_1.jpg" attr= "test-image_1" qwe="asd" attr=" ">
<img attr="a attr b" src="/test-imagalte_1.jpg" attr qwe="asd" />
<img src="/test- alt image_1.jpg" attr="test-image_1" attr= "" qwe="asd" >
<img src="/test-image_1.jpg" attr = " " asd=" q" attr="test-image_1" attr qwe="asd" >
<img src="/test-image_1.jpg" attr= "test-image_1" qwe="asd" attr=" d " attr = " d " attr= " d ">
<img attr="test-image_1" qwe="asd" attr >
<img attr="test-image_1" qwe="asd" battr >
<img attr="test-image_1" qwe="asd" attrh >
<img attr="test-image_1" qwe="asd" attr >
<img attr="test-image_1" qwe="asd" attr =>
<img attr="test-image_1" qwe="asd" attr=>
<img attr="test-image_1" qwe="asd" battr = "" >
<img attr="test-image_1" qwe="asd" attrh= " " >
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)