package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(THE END|FINIS).*`)
var str = `txt <- "... thou hast tam'd a curst shrow. LUCENTIO. 'Tis a wonder,
by your leave, she will be tam'd so. Exeunt THE END <<THIS ELECTRONIC VERSION OF THE COMPLETE WORKS OF WILLIAM ..."
txt <- "... thou hast tam'd a curst shrow. LUCENTIO. 'Tis a wonder,
by your leave, she will be tam'd so. Exeunt FINIS <<THIS ELECTRONIC VERSION OF THE COMPLETE WORKS OF WILLIAM ..."`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}