$re = '/(THE END|FINIS).*/';
$str = 'txt <- "... thou hast tam\'d a curst shrow. LUCENTIO. \'Tis a wonder,
by your leave, she will be tam\'d so. Exeunt THE END <<THIS ELECTRONIC VERSION OF THE COMPLETE WORKS OF WILLIAM ..."
txt <- "... thou hast tam\'d a curst shrow. LUCENTIO. \'Tis a wonder,
by your leave, she will be tam\'d so. Exeunt FINIS <<THIS ELECTRONIC VERSION OF THE COMPLETE WORKS OF WILLIAM ..."';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;