re = /(THE END|FINIS).*/
str = 'txt <- "... thou hast tam\'d a curst shrow. LUCENTIO. \'Tis a wonder,
by your leave, she will be tam\'d so. Exeunt THE END <<THIS ELECTRONIC VERSION OF THE COMPLETE WORKS OF WILLIAM ..."
txt <- "... thou hast tam\'d a curst shrow. LUCENTIO. \'Tis a wonder,
by your leave, she will be tam\'d so. Exeunt FINIS <<THIS ELECTRONIC VERSION OF THE COMPLETE WORKS OF WILLIAM ..."'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result