#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "([TtEeGgiHu]{2}[0-9/()G]+)\s+([\S]+)\s+([\S]+)\s+(.+\n)"
Local $sString = "Gi0/0/0/7 up up Conexao ao RTACRJO0104 [Gi0/0]" & @CRLF & _
"PO0/0/3/0 down down Conexao ao RTECCPS0101 [POS4/0] BBIP-PTA ## 70NQT5049 NQT ## - DESATIVANDO" & @CRLF & _
"PO0/0/3/1 up up Conexao ao RTECVRD0101 [POS3/0] // VRDRJOCPL030194 ACCID 029524" & @CRLF & _
"PO0/0/3/2 up up Conexao ao RTECCPS0101 [POS4/0]" & @CRLF & _
"PO0/0/3/3 admin-down admin-down " & @CRLF & _
"Te0/1/0/0 admin-down admin-down Conexao ao RTICRJO0101 [Ten0/0/0/4]" & @CRLF & _
"Te0/1/0/1 admin-down admin-down Conexao ao RTICRJO0102 [Ten0/4/0/12]" & @CRLF & _
"Te0/1/0/2 up up Conexao ao RTEDRJO0101 [xe-0/2/0]" & @CRLF & _
"Te0/1/0/13 up up Conexao ao RTEDRJO0101 [xe-0/3/0]" & @CRLF & _
"Hu0/2/0/0 up up Conexao ao RTICRJO0101 [HundredGigE0/1/0/0]" & @CRLF & _
"Hu0/4/0/0 up up Conexao ao RTICRJO0101 [HundredGigE0/1/0/0]" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")