const regex = new RegExp('([TtEeGgiHu]{2}[0-9/()G]+)\\s+([\\S]+)\\s+([\\S]+)\\s+(.+\\n)', 'g')
const str = `Gi0/0/0/7 up up Conexao ao RTACRJO0104 [Gi0/0]
PO0/0/3/0 down down Conexao ao RTECCPS0101 [POS4/0] BBIP-PTA ## 70NQT5049 NQT ## - DESATIVANDO
PO0/0/3/1 up up Conexao ao RTECVRD0101 [POS3/0] // VRDRJOCPL030194 ACCID 029524
PO0/0/3/2 up up Conexao ao RTECCPS0101 [POS4/0]
PO0/0/3/3 admin-down admin-down
Te0/1/0/0 admin-down admin-down Conexao ao RTICRJO0101 [Ten0/0/0/4]
Te0/1/0/1 admin-down admin-down Conexao ao RTICRJO0102 [Ten0/4/0/12]
Te0/1/0/2 up up Conexao ao RTEDRJO0101 [xe-0/2/0]
Te0/1/0/13 up up Conexao ao RTEDRJO0101 [xe-0/3/0]
Hu0/2/0/0 up up Conexao ao RTICRJO0101 [HundredGigE0/1/0/0]
Hu0/4/0/0 up up Conexao ao RTICRJO0101 [HundredGigE0/1/0/0]
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}