import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([TtEeGgiHu]{2}[0-9/()G]+)\\s+([\\S]+)\\s+([\\S]+)\\s+(.+\\n)";
final String string = "Gi0/0/0/7 up up Conexao ao RTACRJO0104 [Gi0/0]\n"
+ "PO0/0/3/0 down down Conexao ao RTECCPS0101 [POS4/0] BBIP-PTA ## 70NQT5049 NQT ## - DESATIVANDO\n"
+ "PO0/0/3/1 up up Conexao ao RTECVRD0101 [POS3/0] // VRDRJOCPL030194 ACCID 029524\n"
+ "PO0/0/3/2 up up Conexao ao RTECCPS0101 [POS4/0]\n"
+ "PO0/0/3/3 admin-down admin-down \n"
+ "Te0/1/0/0 admin-down admin-down Conexao ao RTICRJO0101 [Ten0/0/0/4]\n"
+ "Te0/1/0/1 admin-down admin-down Conexao ao RTICRJO0102 [Ten0/4/0/12]\n"
+ "Te0/1/0/2 up up Conexao ao RTEDRJO0101 [xe-0/2/0]\n"
+ "Te0/1/0/13 up up Conexao ao RTEDRJO0101 [xe-0/3/0]\n"
+ "Hu0/2/0/0 up up Conexao ao RTICRJO0101 [HundredGigE0/1/0/0]\n"
+ "Hu0/4/0/0 up up Conexao ao RTICRJO0101 [HundredGigE0/1/0/0]\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}