package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:image:\s+name:\s*|image:\s*|services:\s+-\s+|FROM\s+)(?<depName>[\S]+):(?<currentValue>[\S]+)`)
var str = `job2:
image:
name: docker:23.0.6-alpine3.17
services:
- docker:23.0.6-dind-alpine3.17
variables:
DOCKER_DRIVER: overlay2
script:
- echo test 2
job3:
image: hadolint/hadolint:v2.12.0-alpine
script:
- echo test 3
include:
- local: test.gitlab-ci.yml
job1:
image: python:3.11.4-alpine3.17
script:
- echo test 1
FROM python:3.11.4-alpine3.17
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}