const regex = /(?:image:\s+name:\s*|image:\s*|services:\s+-\s+|FROM\s+)(?<depName>[\S]+):(?<currentValue>[\S]+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:image:\\s+name:\\s*|image:\\s*|services:\\s+-\\s+|FROM\\s+)(?<depName>[\\S]+):(?<currentValue>[\\S]+)', 'g')
const str = `job2:
image:
name: docker:23.0.6-alpine3.17
services:
- docker:23.0.6-dind-alpine3.17
variables:
DOCKER_DRIVER: overlay2
script:
- echo test 2
job3:
image: hadolint/hadolint:v2.12.0-alpine
script:
- echo test 3
include:
- local: test.gitlab-ci.yml
job1:
image: python:3.11.4-alpine3.17
script:
- echo test 1
FROM python:3.11.4-alpine3.17
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}