# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:image:\s+name:\s*|image:\s*|services:\s+-\s+|FROM\s+)(?<depName>[\S]+):(?<currentValue>[\S]+)"
test_str = ("job2:\n"
" image:\n"
" name: docker:23.0.6-alpine3.17\n"
" services:\n"
" - docker:23.0.6-dind-alpine3.17\n"
" variables:\n"
" DOCKER_DRIVER: overlay2\n"
" script:\n"
" - echo test 2\n\n"
"job3:\n"
" image: hadolint/hadolint:v2.12.0-alpine\n"
" script:\n"
" - echo test 3\n\n"
"include:\n"
" - local: test.gitlab-ci.yml\n\n"
"job1:\n"
" image: python:3.11.4-alpine3.17\n"
" script:\n"
" - echo test 1\n\n"
"FROM python:3.11.4-alpine3.17\n\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.