import Foundation
let pattern = #"(?:image:\s+name:\s*|image:\s*|services:\s+-\s+|FROM\s+)(?<depName>[\S]+):(?<currentValue>[\S]+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
job2:
image:
name: docker:23.0.6-alpine3.17
services:
- docker:23.0.6-dind-alpine3.17
variables:
DOCKER_DRIVER: overlay2
script:
- echo test 2
job3:
image: hadolint/hadolint:v2.12.0-alpine
script:
- echo test 3
include:
- local: test.gitlab-ci.yml
job1:
image: python:3.11.4-alpine3.17
script:
- echo test 1
FROM python:3.11.4-alpine3.17
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)