using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[()=]|\{[^\}]+\}|[+-]|[^=]+$";
string input = @"({1+1=2|2+2=4}+{1+2=3|2+3=5})=16+10";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}