$re = '/[()=]|\{[^\}]+\}|[+-]|[^=]+$/';
$str = '({1+1=2|2+2=4}+{1+2=3|2+3=5})=16+10';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);