package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[()=]|\{[^\}]+\}|[+-]|[^=]+$`)
var str = `({1+1=2|2+2=4}+{1+2=3|2+3=5})=16+10`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}