// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[()=]|\{[^\}]+\}|[+-]|[^=]+$").unwrap();
let string = "({1+1=2|2+2=4}+{1+2=3|2+3=5})=16+10";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}