package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<\/?p>`)
var str = `<p>Be very careful about summoning deamons this early in the morning. They haven't had any coffee yet.</p>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}