const regex = /<\/?p>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<\\\/?p>', 'g')
const str = `<p>Be very careful about summoning deamons this early in the morning. They haven't had any coffee yet.</p>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}