re = /<\/?p>/
str = '<p>Be very careful about summoning deamons this early in the morning. They haven\'t had any coffee yet.</p>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end