$re = '/<\/?p>/';
$str = '<p>Be very careful about summoning deamons this early in the morning. They haven\'t had any coffee yet.</p>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);