package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\[\w+]\s+)\[(\w+)]`)
var str = `[AddressId] [int] NOT NULL,
[CountryId] [int] NULL,
[POBoxCountryId] [int] NULL,
[Name] [nvarchar] (100) NULL,`
var substitution = "$1$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}