re = /(\[\w+]\s+)\[(\w+)]/m
str = '[AddressId] [int] NOT NULL,
[CountryId] [int] NULL,
[POBoxCountryId] [int] NULL,
[Name] [nvarchar] (100) NULL,'
subst = '$1$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result