const regex = /(\[\w+]\s+)\[(\w+)]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\[\\w+]\\s+)\\[(\\w+)]', 'gm')
const str = `[AddressId] [int] NOT NULL,
[CountryId] [int] NULL,
[POBoxCountryId] [int] NULL,
[Name] [nvarchar] (100) NULL,`;
const subst = `$1$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);