#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<ValueTolerance>([^\w|\S])([\±]+?\d+?[%])([\s]))"
Local $sString = "SMD 0603 q49 ,91111111 Ом ±1% 0,1 Вт CR0603-FX-49R9ELF" & @CRLF & _
"SMD 0603 123.999Ом ± 1% 0,1Вт CR0603-FX-49R9ELF" & @CRLF & _
"" & @CRLF & _
"SMD 0603 49,9Ом ±1% 0,1 Вт CR0603-FX-49R9ELF" & @CRLF & _
"SMD 0603 49,9ккОм ± 1% 0,1Вт CR0603-FX-49R9ELF" & @CRLF & _
"" & @CRLF & _
"SMD 0603 9.99Ом ±1% 0,1 Вт CR0603-FX-49R9ELF" & @CRLF & _
"SMD 0603 9.99кОм ± 1% 0,1Вт CR0603-FX-49R9ELF" & @CRLF & _
"" & @CRLF & _
"SMD 0603 49,9 МОм ±1% 0.1 Вт CR0603-FX-49R9ELF" & @CRLF & _
"SMD 0603 49.9 ГОм ± 1% 0.1Вт CR0603-FX-49R9ELF" & @CRLF & _
"" & @CRLF & _
"SMD 0603 49,9МОм ±1% 0.1 Вт CR0603-FX-49R9ELF" & @CRLF & _
"SMD 0603 49,9ГОм ± 1% 0.1Вт CR0603-FX-49R9ELF" & @CRLF & _
"" & @CRLF & _
"SMD 0603 49,9 мОм ±1% 0.11 Вт CR0603-FX-49R9ELF" & @CRLF & _
"SMD 0603 49,9 мкОм ± 1% 0.11Вт CR0603-FX-49R9ELF" & @CRLF & _
"" & @CRLF & _
"SMD 0805 100 нФ ± 10 % 50 В X7R 08055C104KAT2A AVX" & @CRLF & _
"SMD 0805 100 нФ ±10% 50В X7R 08055C104KAT2A AVX" & @CRLF & _
"" & @CRLF & _
"SMD 0805 100 нФ ± 10 % 50.0 В X7R 08055C104KAT2A AVX" & @CRLF & _
"SMD 0805 100 нФ ±10% 50.0В X7R 08055C104KAT2A AVX" & @CRLF & _
"" & @CRLF & _
"ads 50.9Ом erterter" & @CRLF & _
"50.99Вт" & @CRLF & _
"50.9 В" & @CRLF & _
"50.999 Вт" & @CRLF & _
"а50 мФ" & @CRLF & _
"100.00 мкФ" & @CRLF & _
"100.00 нФ" & @CRLF & _
"100.00 пФ" & @CRLF & _
"10 мкФ" & @CRLF & _
"0123456789 мФ" & @CRLF & _
"0,123456789 мФ" & @CRLF & _
"0.123456789 мФ"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")