import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<ValueTolerance>([^\\w|\\S])([\\±]+?\\d+?[%])([\\s]))";
final String string = "SMD 0603 q49 ,91111111 Ом ±1% 0,1 Вт CR0603-FX-49R9ELF\n"
+ "SMD 0603 123.999Ом ± 1% 0,1Вт CR0603-FX-49R9ELF\n\n"
+ "SMD 0603 49,9Ом ±1% 0,1 Вт CR0603-FX-49R9ELF\n"
+ "SMD 0603 49,9ккОм ± 1% 0,1Вт CR0603-FX-49R9ELF\n\n"
+ "SMD 0603 9.99Ом ±1% 0,1 Вт CR0603-FX-49R9ELF\n"
+ "SMD 0603 9.99кОм ± 1% 0,1Вт CR0603-FX-49R9ELF\n\n"
+ "SMD 0603 49,9 МОм ±1% 0.1 Вт CR0603-FX-49R9ELF\n"
+ "SMD 0603 49.9 ГОм ± 1% 0.1Вт CR0603-FX-49R9ELF\n\n"
+ "SMD 0603 49,9МОм ±1% 0.1 Вт CR0603-FX-49R9ELF\n"
+ "SMD 0603 49,9ГОм ± 1% 0.1Вт CR0603-FX-49R9ELF\n\n"
+ "SMD 0603 49,9 мОм ±1% 0.11 Вт CR0603-FX-49R9ELF\n"
+ "SMD 0603 49,9 мкОм ± 1% 0.11Вт CR0603-FX-49R9ELF\n\n"
+ "SMD 0805 100 нФ ± 10 % 50 В X7R 08055C104KAT2A AVX\n"
+ "SMD 0805 100 нФ ±10% 50В X7R 08055C104KAT2A AVX\n\n"
+ "SMD 0805 100 нФ ± 10 % 50.0 В X7R 08055C104KAT2A AVX\n"
+ "SMD 0805 100 нФ ±10% 50.0В X7R 08055C104KAT2A AVX\n\n"
+ "ads 50.9Ом erterter\n"
+ "50.99Вт\n"
+ "50.9 В\n"
+ "50.999 Вт\n"
+ "а50 мФ\n"
+ "100.00 мкФ\n"
+ "100.00 нФ\n"
+ "100.00 пФ\n"
+ "10 мкФ\n"
+ "0123456789 мФ\n"
+ "0,123456789 мФ\n"
+ "0.123456789 мФ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}