package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(([a-zA-Z]:[/\\]|\\\\)([0-9a-zA-Z_\-. ]+[/\\]?)*)|([0-9a-zA-Z_\-\\/.][0-9a-zA-Z_\-\\/. ]*)|(^$)`)
var str = `/test.txt
test.txt
C:\test.txt
D:\test\test2.txt
asdfasdf
abcd :Dasdfrew
hbkj23j;nlkfsld khjasdf
adsfpoiuhasef pn9y8hqwer 98uhqwef;olnkqw234r'l;,qwetfs
test/test.txt
C:/test.txt
C:\test/test.txt
C:\/test.txt
C:/\test.txt
aa:\
C:\\test.txt
C:/\test.txt
\test.txt
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}