use strict;
my $str = '/test.txt
test.txt
C:\\test.txt
D:\\test\\test2.txt
asdfasdf
abcd :Dasdfrew
hbkj23j;nlkfsld khjasdf
adsfpoiuhasef pn9y8hqwer 98uhqwef;olnkqw234r\'l;,qwetfs
test/test.txt
C:/test.txt
C:\\test/test.txt
C:\\/test.txt
C:/\\test.txt
aa:\\
C:\\\\test.txt
C:/\\test.txt
\\test.txt
';
my $regex = qr/(([a-zA-Z]:[/\\]|\\\\)([0-9a-zA-Z_\-. ]+[/\\]?)*)|([0-9a-zA-Z_\-\\/.][0-9a-zA-Z_\-\\/. ]*)|(^$)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}