using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^\/]+)(?=\/[^\/]+$)";
string input = @"/my/name/is/the/following/string/name.lastname/file.txt
1moreFldr/my/name/is/the/following/string/name.lastname/file.txt
1MoreFldr/2moreFldr/my/name/is/the/following/string/name.lastname/file.txt";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}