$re = '/([^\/]+)(?=\/[^\/]+$)/im';
$str = '/my/name/is/the/following/string/name.lastname/file.txt
1moreFldr/my/name/is/the/following/string/name.lastname/file.txt
1MoreFldr/2moreFldr/my/name/is/the/following/string/name.lastname/file.txt';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);