const regex = /([^\/]+)(?=\/[^\/]+$)/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([^\\\/]+)(?=\\\/[^\\\/]+$)', 'gim')
const str = `/my/name/is/the/following/string/name.lastname/file.txt
1moreFldr/my/name/is/the/following/string/name.lastname/file.txt
1MoreFldr/2moreFldr/my/name/is/the/following/string/name.lastname/file.txt`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}