import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([^\\/]+)(?=\\/[^\\/]+$)";
final String string = "/my/name/is/the/following/string/name.lastname/file.txt\n"
+ "1moreFldr/my/name/is/the/following/string/name.lastname/file.txt\n"
+ "1MoreFldr/2moreFldr/my/name/is/the/following/string/name.lastname/file.txt";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}