package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`OPTIONS=\"(.*?)(-u\s[A-Za-z0-9\-_]+:[A-Za-z0-9\-_]+)?(.*?)\"`)
var str = `OPTIONS="-x -u wrong:wrong -c blah"
OPTIONS="-u wrong:wrong -x -c blah"
OPTIONS="-x -c blah -u wrong:wrong"
OPTIONS="-x -c blah"
`
var substitution = "OPTIONS="\1 \3 -u ntpd:ntpd""
fmt.Println(re.ReplaceAllString(str, substitution))
}