use strict;
my $str = 'OPTIONS="-x -u wrong:wrong -c blah"
OPTIONS="-u wrong:wrong -x -c blah"
OPTIONS="-x -c blah -u wrong:wrong"
OPTIONS="-x -c blah"
';
my $regex = qr/OPTIONS=\"(.*?)(-u\s[A-Za-z0-9\-_]+:[A-Za-z0-9\-_]+)?(.*?)\"/p;
my $subst = 'OPTIONS="\\1 \\3 -u ntpd:ntpd"';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";