# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=<a href=\")([^"]*)-([^&"]*)(?=\.html\">)/$1_$2/gm;t' <<< "<div id=\"breadcrumb-section\">
<ol id=\"breadcrumbs\">
<li class=\"first\">
<span>
<a href=\"index.html\">Technologies</a>
</span>
</li>
<li>
<span>
<a href=\"Some-Technologies-Documentation_218464400.html\">Some Technologies Documentation</a>
</span>
</li>
<li>
<span>
<a href=\"Some-Other-Documentation_268370090.html\">Some Other Documentation</a>
</span>
</li>
<li>
<span>
<a href=\"Another-Documentation_268370112.html\">Another Documentation</a>
</span>
</li>
</ol>
</div>"