import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=<a href=\\\")([^\"]*)-([^&\"]*)(?=\\.html\\\">)";
final String string = "<div id=\"breadcrumb-section\">\n"
+ " <ol id=\"breadcrumbs\">\n"
+ " <li class=\"first\">\n"
+ " <span>\n"
+ " <a href=\"index.html\">Technologies</a>\n"
+ " </span>\n"
+ " </li>\n"
+ " <li>\n"
+ " <span>\n"
+ " <a href=\"Some-Technologies-Documentation_218464400.html\">Some Technologies Documentation</a>\n"
+ " </span>\n"
+ " </li>\n"
+ " <li>\n"
+ " <span>\n"
+ " <a href=\"Some-Other-Documentation_268370090.html\">Some Other Documentation</a>\n"
+ " </span>\n"
+ " </li>\n"
+ " <li>\n"
+ " <span>\n"
+ " <a href=\"Another-Documentation_268370112.html\">Another Documentation</a>\n"
+ " </span>\n"
+ " </li>\n"
+ " </ol>\n"
+ "</div>";
final String subst = "$1_$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}